Platform issue affecting log in & sign ups.
Incident Report for
SquaredUp Cloud
Resolved
This incident has been resolved.
Posted
Oct
09
,
2025
-
18:35
UTC
Update
We are continuing to monitor for any further issues.
Posted
Oct
09
,
2025
-
18:34
UTC
Monitoring
Azure have reported an incident with Front Door (
https://azure.status.microsoft/en-gb/status
). This may impact attempted sign in and signup attempts.
Posted
Oct
09
,
2025
-
10:55
UTC
This incident affected: SquaredUp - Web Application.
×
Subscribe to Incident
Subscribe to updates for
Platform issue affecting log in & sign ups.
via . You'll receive .