The issue appears to be related to a Cloudflare outage, for which they have now implemented a fix. We will continue to monitor the platform for any further outages/ degradation.
Posted Dec 05, 2025 - 09:20 UTC
Investigating
We are currently investigating an issue that's affecting logging into the platform. We will provide and update and as soon as we have more information.
Posted Dec 05, 2025 - 09:16 UTC
This incident affected: SquaredUp - Web Application.